Microsoft 365 is experiencing an outage affecting logging in

Incident Report for PDQ

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2026 - 16:43 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 02, 2026 - 16:16 EDT

Identified

Microsoft 365 is experiencing an outage affecting logging in that is affecting some of customer ability to login
Posted Jun 02, 2026 - 15:35 EDT
This incident affects: Connect (Web Admin).