SmartDeploy: Azure Region Outage causing slowness/unavailability of services
Incident Report for PDQ
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 22:25 MDT
Identified
An ongoing Azure region outage is causing degraded performance and unavailability of some services for SmartDeploy.
Posted Jul 18, 2024 - 17:38 MDT
This incident affected: SmartDeploy.