SimpleMDM degraded service - increase in Cloudflare errors

Incident Report for PDQ

Resolved

This incident has been resolved
Posted Mar 21, 2025 - 17:40 MDT

Monitoring

We are experiencing issues related to our upstream service provider Cloudflare. This is impacting app uploads and some configuration profile distribution. Cloudflare has indicated they are currently implementing a fix.
Posted Mar 21, 2025 - 16:51 MDT
This incident affected: SimpleMDM (App Upload Processing, Configuration Profile Distribution).