SimpleMDM Degrade Performance

Incident Report for PDQ

Resolved

After after deploying a performance improvement on 07/28, we are seeing consistent throughput for app installations. This incident has been resolved.
Posted Jul 29, 2025 - 16:02 EDT

Update

Some customers may experience slow app installation rollouts.
Posted Jul 28, 2025 - 19:41 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 28, 2025 - 19:40 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2025 - 10:54 EDT

Update

We are continuing to investigate this issue.
Posted Jul 28, 2025 - 10:54 EDT

Investigating

SimpleMDM is experiencing degraded performance. Some deployments may be delayed.
Posted Jul 28, 2025 - 10:53 EDT
This incident affected: SimpleMDM (App Licensing and Distribution, Configuration Profile Distribution, Apple Business Manager Device Assignment Sync (DEP)).