Connect: Some devices managed by PDQ Connect are running at 100% CPU

Incident Report for PDQ

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 12:20 MDT

Monitoring

A fix has been implemented and things seem to have returned to normal behavior for devices. We're currently running some additional checks and monitoring the results.
Posted Mar 19, 2025 - 08:37 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 19, 2025 - 08:29 MDT

Investigating

We have received multiple reports indicating that some devices running the PDQ Connect agent are reaching 100% CPU utilization. We're actively investigating this issue to determine cause and impact.
Posted Mar 19, 2025 - 07:00 MDT
This incident affected: Connect (PDQ Connect Agent).