Delay in group count updates

Incident Report for PDQ

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 19:45 EDT

Monitoring

A fix has been implemented and we are monitoring the results
Posted Jul 27, 2026 - 19:09 EDT

Investigating

Except a delay in group recalculations. Features that rely on group counts such as automations will also be delayed while waiting for updates.
Posted Jul 27, 2026 - 18:15 EDT
This incident affected: Connect (Automations, Device Scans, Reports).