SImpleMDM Outage

Incident Report for PDQ

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 00:53 EST

Investigating

We are currently investigating an issue affecting all systems and will update our status as we understand the issue.
Posted Feb 19, 2026 - 23:35 EST
This incident affected: SimpleMDM (App Licensing and Distribution, App Upload Processing, Configuration Profile Distribution, Apple Business Manager Device Assignment Sync (DEP)).