Some deployments are slowed or stuck

Incident Report for PDQ

Resolved

The deployment issue has been resolved.
Posted May 27, 2025 - 10:01 EDT

Monitoring

The fix has been deployed. We are currently monitoring the issue through tomorrow morning.
Posted May 26, 2025 - 21:17 EDT

Identified

We identified a possible fix and are deploying it ASAP.
Posted May 26, 2025 - 20:08 EDT

Investigating

We are investigating an issue where some deployments are stuck in a queue and may take longer than usual. It's unclear yet how long these deployments will take.
Posted May 26, 2025 - 19:29 EDT
This incident affected: Connect (Deployments).