Connect: Console is experiencing general slowness

Incident Report for PDQ

Resolved

This incident has been resolved.
Posted Apr 28, 2025 - 13:26 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2025 - 11:38 MDT

Update

Group count calculations are in a degraded state and might show incorrect values. All other services are fully operational. We are actively investigating a fix for group counts.
Posted Apr 28, 2025 - 10:43 MDT

Update

There was a brief system change that may have caused additional errors and we are continuing to investigate.
Posted Apr 28, 2025 - 10:28 MDT

Update

The system is more stable now, but some background processes are still delayed. Our team is working on a solution to get things fully back to normal. We'll share more updates as we make progress.
Posted Apr 28, 2025 - 09:31 MDT

Update

We are encountering general slowness across our Connect product. The team is investigating we'll have an update within the next 30 minutes.
Posted Apr 28, 2025 - 07:54 MDT

Investigating

We are currently investigating this issue.
Posted Apr 28, 2025 - 07:30 MDT
This incident affected: Connect (Web Admin).