Some Connect devices are offline and scans are currently delayed

Incident Report for PDQ

Resolved

Incident resolved devices are online and scanning at normal speed.
Posted Oct 15, 2025 - 11:36 EDT

Monitoring

We've identified the issue and are currently monitoring it.
Posted Oct 15, 2025 - 11:16 EDT

Investigating

Connect scans are seeing a delay, and some devices are shown as offline. Scans are taking longer than usual to complete.
Posted Oct 15, 2025 - 10:12 EDT
This incident affected: Connect (Device Scans).