Connect degraded performance

Incident Report for PDQ

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 11:12 EDT

Identified

The team has identified some likely causes and is working on remediation options.
Posted Aug 07, 2025 - 10:57 EDT

Investigating

Connect is experiencing degraded performance. We are currently investigating this issue.
Posted Aug 07, 2025 - 10:34 EDT
This incident affected: Connect (Automations, Deployments, Device Scans, Package Library, Remote Desktop, Reports, Vulnerability Management, Web Admin).